The incident is now resolved and all systems are now fully operational.
Root Cause Analysis (RCA):
Earlier today, we experienced intermittent instability across portions of the platform due to elevated system load caused by a rogue internal process that unintentionally generated a large burst of requests against backend services.
The engineering team mitigated the issue by stabilizing impacted services and reducing request pressure. All systems and operations have now fully recovered and are operating normally.
As part of our follow-up work, we are implementing additional safeguards and resiliency improvements, including:
Enhanced rate limiting and burst protection on sensitive internal endpoints Additional service-level protections around request concurrency Expanded monitoring and automated alerting for abnormal traffic patterns Additional operational safeguards around large-scale internal tooling/scripts
We appreciate everyone’s patience and understanding.
Posted May 23, 2026 - 02:50 UTC
Update
Our systems are gradually recovering and service availability is steadily improving. The team is continuing to monitor stability and bring remaining systems back online safely.
We’ll continue providing updates as recovery progresses. Thank you for your patience.
Posted May 23, 2026 - 00:04 UTC
Identified
The issue has been identified. Should see systems coming back within the next 1-2 hours.
Posted May 22, 2026 - 21:49 UTC
Investigating
The API is currently unavailable. Our team is actively working to restore service. We will provide an update within 30 minutes.