Degraded AWS performance impacting other 3rd party systems

Incident Report for Alpine IQ

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 03:23 UTC

Update

One of our third-party systems used for creating marketing campaigns is currently affected by this issue. You may experience problems editing campaign designs or uploading images.
Posted Oct 20, 2025 - 16:57 UTC

Monitoring

AWS (Amazon Web Services) is currently experiencing degraded performance across multiple services.
This may impact multiple 3rd party systems in your tech stack.

Please see https://health.aws.amazon.com/health/status for more info.
Posted Oct 20, 2025 - 15:22 UTC